Menu

Star on GitHub · 3.3k

CVE-2020-15182

8.4 · HIGH

The SOY Inquiry component of SOY CMS is affected by Cross-site Request Forgery (CSRF) and Remote Code Execution (RCE).

Published Sep 17, 2020CWE-22EPSS 1.17%

Overview

CVE-2020-15182 is a high-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 8.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

The SOY Inquiry component of SOY CMS is affected by Cross-site Request Forgery (CSRF) and Remote Code Execution (RCE). The vulnerability affects versions 2.0.0.3 and earlier of SOY Inquiry. This allows remote attackers to force the administrator to edit files once the administrator loads a specially crafted webpage. An administrator must be logged in for exploitation to be possible. This issue is fixed in SOY Inquiry version 2.0.0.4 and included in SOY CMS 3.0.2.328.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-15182?

CVE-2020-15182 is a high-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 8.4 (HIGH).

How severe is CVE-2020-15182?

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-15182?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-15182?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-15182 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2020

View all
LiveWatch live →