Menu

Star on GitHub · 3.3k

CVE-2020-26273

5.2 · MEDIUM

osquery is a SQL powered operating system instrumentation, monitoring, and analytics framework.

Published Dec 16, 2020CWE-77EPSS 0.95%

Overview

CVE-2020-26273 is a medium-severity vulnerability. It was published on December 16, 2020 and has a CVSS 3.1 base score of 5.2 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

osquery is a SQL powered operating system instrumentation, monitoring, and analytics framework. In osquery before version 4.6.0, by using sqlite's ATTACH verb, someone with administrative access to osquery can cause reads and writes to arbitrary sqlite databases on disk. This _does_ allow arbitrary files to be created, but they will be sqlite databases. It does not appear to allow existing non-sqlite files to be overwritten. This has been patched in osquery 4.6.0. There are several mitigating factors and possible workarounds. In some deployments, the people with access to these interfaces may be considered administrators. In some deployments, configuration is managed by a central tool. This tool can filter for the `ATTACH` keyword. osquery can be run as non-root user. Because this also limits the desired access levels, this requires deployment specific testing and configuration.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-26273?

CVE-2020-26273 is a medium-severity vulnerability. It was published on December 16, 2020 and has a CVSS 3.1 base score of 5.2 (MEDIUM).

How severe is CVE-2020-26273?

This vulnerability has a CVSS 3.1 base score of 5.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-26273?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-26273?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-26273 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2020

View all
LiveWatch live →