Menu

Star on GitHub · 3.3k

CVE-2021-21277

8.5 · HIGH

angular-expressions is "angular's nicest part extracted as a standalone module for the browser and node".

Published Feb 1, 2021CWE-74EPSS 2.73%

Overview

CVE-2021-21277 is a high-severity vulnerability. It was published on February 1, 2021 and has a CVSS 3.1 base score of 8.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

angular-expressions is "angular's nicest part extracted as a standalone module for the browser and node". In angular-expressions before version 1.1.2 there is a vulnerability which allows Remote Code Execution if you call "expressions.compile(userControlledInput)" where "userControlledInput" is text that comes from user input. The security of the package could be bypassed by using a more complex payload, using a ".constructor.constructor" technique. In terms of impact: If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. This is fixed in version 1.1.2 of angular-expressions A temporary workaround might be either to disable user-controlled input that will be fed into angular-expressions in your application or allow only following characters in the use

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2021-21277?

CVE-2021-21277 is a high-severity vulnerability. It was published on February 1, 2021 and has a CVSS 3.1 base score of 8.5 (HIGH).

How severe is CVE-2021-21277?

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2021-21277?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2021-21277?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2021-21277 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2021

View all
LiveWatch live →