CVE-2021-21381
7.1 · HIGHFlatpak is a system for building, distributing, and running sandboxed desktop applications on Linux.
Overview
CVE-2021-21381 is a high-severity vulnerability. It was published on March 11, 2021 and has a CVSS 3.1 base score of 7.1 (HIGH).
This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.
Technical description
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In Flatpack since version 0.9.4 and before version 1.10.2 has a vulnerability in the "file forwarding" feature which can be used by an attacker to gain access to files that would not ordinarily be allowed by the app's permissions. By putting the special tokens `@@` and/or `@@u` in the Exec field of a Flatpak app's .desktop file, a malicious app publisher can trick flatpak into behaving as though the user had chosen to open a target file with their Flatpak app, which automatically makes that file available to the Flatpak app. This is fixed in version 1.10.2. A minimal solution is the first commit "`Disallow @@ and @@U usage in desktop files`". The follow-up commits "`dir: Reserve the whole @@ prefix`" and "`dir: Refuse to export .desktop files with suspicious uses of @@ tokens`" are recommended, but not strictly required. As a workaround, avoid installing Flatpak apps from untrusted sour
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2021-21381?
CVE-2021-21381 is a high-severity vulnerability. It was published on March 11, 2021 and has a CVSS 3.1 base score of 7.1 (HIGH).
How severe is CVE-2021-21381?
This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2021-21381?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2021-21381?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2021-21381 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related HIGH CVEs from 2021
View all- 8.9CVE-2021-21388
systeminformation is an open source system and OS information library for node.js. A command injecti
View details - 8.9CVE-2021-35213
An Improper Access Control Privilege Escalation Vulnerability was discovered in the User Setting of
View details - 8.9CVE-2021-35212
An SQL injection Privilege Escalation Vulnerability was discovered in the Orion Platform reported by
View details - 8.9CVE-2021-35215
Insecure deserialization leading to Remote Code Execution was detected in the Orion Platform version
View details - 8.9CVE-2021-35216
Insecure Deserialization of untrusted data remote code execution vulnerability was discovered in Pat
View details - 8.9CVE-2021-35218
Deserialization of Untrusted Data in the Web Console Chart Endpoint can lead to remote code executio
View details - 8.9CVE-2021-35217
Insecure Deseralization of untrusted data remote code execution vulnerability was discovered in Patc
View details - 8.9CVE-2021-38162
SAP Web Dispatcher versions - 7.49, 7.53, 7.77, 7.81, KRNL64NUC - 7.22, 7.22EXT, 7.49, KRNL64UC -7.2
View details - 8.8CVE-2021-21495
MK-AUTH through 19.01 K4.9 allows CSRF for password changes via the central/executar_central.php?aca
View details - 8.8CVE-2020-4917
IBM Cloud Pak System 2.3 is vulnerable to cross-site request forgery which could allow an attacker t
View details - 8.8CVE-2020-4942
IBM Curam Social Program Management 7.0.9 and 7.0.11 is vulnerable to cross-site request forgery whi
View details - 8.8CVE-2020-36158
mwifiex_cmd_802_11_ad_hoc_start in drivers/net/wireless/marvell/mwifiex/join.c in the Linux kernel t
View details
