Menu

Star on GitHub · 3.4k

CVE-2021-32730

5.7 · MEDIUM

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it.

Published Jul 1, 2021CWE-352EPSS 0.61%

Overview

CVE-2021-32730 is a medium-severity vulnerability. It was published on July 1, 2021 and has a CVSS 3.1 base score of 5.7 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A cross-site request forgery vulnerability exists in versions prior to 12.10.5, and in versions 13.0 through 13.1. It's possible for forge an URL that, when accessed by an admin, will reset the password of any user in XWiki. The problem has been patched in XWiki 12.10.5 and 13.2RC1. As a workaround, it is possible to apply the patch manually by modifying the `register_macros.vm` template.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2021-32730?

CVE-2021-32730 is a medium-severity vulnerability. It was published on July 1, 2021 and has a CVSS 3.1 base score of 5.7 (MEDIUM).

How severe is CVE-2021-32730?

This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2021-32730?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2021-32730?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2021-32730 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2021

View all
Watch the demo →