Menu

Star on GitHub · 3.3k

CVE-2022-0758

3.3 · LOW

Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool.

Published Mar 17, 2022CWE-79EPSS 0.43%

Overview

CVE-2022-0758 is a low-severity vulnerability. It was published on March 17, 2022 and has a CVSS 3.1 base score of 3.3 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.3, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool. With this vulnerability an attacker could pass literal values as the test credentials, providing the opportunity for a potential XSS attack. This issue is fixed in Rapid7 Nexpose version 6.6.130.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-0758?

CVE-2022-0758 is a low-severity vulnerability. It was published on March 17, 2022 and has a CVSS 3.1 base score of 3.3 (LOW).

How severe is CVE-2022-0758?

This vulnerability has a CVSS 3.1 base score of 3.3, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2022-0758?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-0758?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-0758 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2022

View all
LiveWatch live →