CVE-2022-21683
3.5 · LOWWagtail is a Django based content management system focused on flexibility and user experience.
Overview
CVE-2022-21683 is a low-severity vulnerability. It was published on January 18, 2022 and has a CVSS 3.1 base score of 3.5 (LOW).
This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
Wagtail is a Django based content management system focused on flexibility and user experience. When notifications for new replies in comment threads are sent, they are sent to all users who have replied or commented anywhere on the site, rather than only in the relevant threads. This means that a user could listen in to new comment replies on pages they have not have editing access to, as long as they have left a comment or reply somewhere on the site. A patched version has been released as Wagtail 2.15.2, which restores the intended behaviour - to send notifications for new replies to the participants in the active thread only (editing permissions are not considered). New comments can be disabled by setting `WAGTAILADMIN_COMMENTS_ENABLED = False` in the Django settings file.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2022-21683?
CVE-2022-21683 is a low-severity vulnerability. It was published on January 18, 2022 and has a CVSS 3.1 base score of 3.5 (LOW).
How severe is CVE-2022-21683?
This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2022-21683?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2022-21683?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-21683 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related LOW CVEs from 2022
View all- 3.9CVE-2022-22287
Abitrary file access vulnerability in Samsung Email prior to 6.1.60.16 allows attacker to read isola
View details - 3.9CVE-2022-21298
Vulnerability in the Oracle Solaris product of Oracle Systems (component: Install). The supported ve
View details - 3.9CVE-2022-23427
PendingIntent hijacking vulnerability in KnoxPrivacyNoticeReceiver prior to SMR Feb-2022 Release 1 a
View details - 3.9CVE-2022-23999
PendingIntent hijacking vulnerability in CpaReceiver prior to SMR Feb-2022 Release 1 allows local at
View details - 3.9CVE-2022-24000
PendingIntent hijacking vulnerability in DataUsageReminderReceiver prior to SMR Feb-2022 Release 1 a
View details - 3.9CVE-2021-25266
An insecure data storage vulnerability allows a physical attacker with root privileges to retrieve T
View details - 3.9CVE-2022-24735
Redis is an in-memory database that persists on disk. By exploiting weaknesses in the Lua script exe
View details - 3.9CVE-2022-29817
In JetBrains IntelliJ IDEA before 2022.1 reflected XSS via error messages in internal web server was
View details - 3.9CVE-2022-29818
In JetBrains IntelliJ IDEA before 2022.1 origin checks in the internal web server were flawed
View details - 3.9CVE-2022-0997
Improper file permissions in the CommandPost, Collector, and Sensor components of Fidelis Network an
View details - 3.9CVE-2022-20226
In finishDrawingWindow of WindowManagerService.java, there is a possible tapjacking due to improper
View details - 3.9CVE-2022-37009
In JetBrains IntelliJ IDEA before 2022.2 local code execution via a Vagrant executable was possible
View details
