Menu

Star on GitHub · 3.3k

CVE-2022-23485

6.4 · MEDIUM

Sentry is an error tracking and performance monitoring platform.

Published Dec 10, 2022CWE-269EPSS 0.43%

Overview

CVE-2022-23485 is a medium-severity vulnerability. It was published on December 10, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-23485?

CVE-2022-23485 is a medium-severity vulnerability. It was published on December 10, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

How severe is CVE-2022-23485?

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2022-23485?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-23485?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-23485 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2022

View all
LiveWatch live →