Menu

Star on GitHub · 3.3k

CVE-2022-23530

5.8 · MEDIUM

GuardDog is a CLI tool to identify malicious PyPI packages.

Published Dec 16, 2022CWE-22EPSS 0.72%

Overview

CVE-2022-23530 is a medium-severity vulnerability. It was published on December 16, 2022 and has a CVSS 3.1 base score of 5.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

GuardDog is a CLI tool to identify malicious PyPI packages. Versions prior to v0.1.8 are vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package. Extracting files using shutil.unpack_archive() from a potentially malicious tarball without validating that the destination file path is within the intended destination directory can cause files outside the destination directory to be overwritten. This issue is patched in version 0.1.8. Potential workarounds include using a safer module, like zipfile, and validating the location of the extracted files and discarding those with malicious paths.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-23530?

CVE-2022-23530 is a medium-severity vulnerability. It was published on December 16, 2022 and has a CVSS 3.1 base score of 5.8 (MEDIUM).

How severe is CVE-2022-23530?

This vulnerability has a CVSS 3.1 base score of 5.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2022-23530?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-23530?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-23530 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2022

View all
LiveWatch live →