Menu

Star on GitHub · 3.3k

CVE-2022-23554

6.5 · MEDIUM

Alpine is a scaffolding library in Java.

Published Dec 28, 2022CWE-287EPSS 0.69%

Overview

CVE-2022-23554 is a medium-severity vulnerability. It was published on December 28, 2022 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Alpine is a scaffolding library in Java. Alpine prior to version 1.10.4 allows Authentication Filter bypass. The AuthenticationFilter relies on the request URI to evaluate if the user is accessing the swagger endpoint. By accessing a URL with a path such as /api/foo;%2fapi%2fswagger the contains condition will hold and will return from the authentication filter without aborting the request. Note that the principal object will not be assigned and therefore the issue wont allow user impersonation. This issue has been fixed in version 1.10.4. There are no known workarounds.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-23554?

CVE-2022-23554 is a medium-severity vulnerability. It was published on December 28, 2022 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

How severe is CVE-2022-23554?

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2022-23554?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-23554?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-23554 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2022

View all
LiveWatch live →