Menu

Star on GitHub · 3.4k

CVE-2022-31146

6.4 · MEDIUM

Wasmtime is a standalone runtime for WebAssembly.

Published Jul 21, 2022CWE-416EPSS 1.25%

Overview

CVE-2022-31146 is a medium-severity vulnerability. It was published on July 21, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Wasmtime is a standalone runtime for WebAssembly. There is a bug in the Wasmtime's code generator, Cranelift, where functions using reference types may be incorrectly missing metadata required for runtime garbage collection. This means that if a GC happens at runtime then the GC pass will mistakenly think these functions do not have live references to GC'd values, reclaiming them and deallocating them. The function will then subsequently continue to use the values assuming they had not been GC'd, leading later to a use-after-free. This bug was introduced in the migration to the `regalloc2` register allocator that occurred in the Wasmtime 0.37.0 release on 2022-05-20. This bug has been patched and users should upgrade to Wasmtime version 0.38.2. Mitigations for this issue can be achieved by disabling the reference types proposal by passing `false` to `wasmtime::Config::wasm_reference_types` or downgrading to Wasmtime 0.36.0 or prior.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-31146?

CVE-2022-31146 is a medium-severity vulnerability. It was published on July 21, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

How severe is CVE-2022-31146?

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2022-31146?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-31146?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-31146 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2022

View all
LiveWatch live →