CVE-2022-46172
6.4 · MEDIUMauthentik is an open-source Identity provider focused on flexibility and versatility.
Overview
CVE-2022-46172 is a medium-severity vulnerability. It was published on December 28, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
authentik is an open-source Identity provider focused on flexibility and versatility. In versions prior to 2022.10.4, and 2022.11.4, any authenticated user can create an arbitrary number of accounts through the default flows. This would circumvent any policy in a situation where it is undesirable for users to create new accounts by themselves. This may also affect other applications as these new basic accounts would exist throughout the SSO infrastructure. By default the newly created accounts cannot be logged into as no password reset exists by default. However password resets are likely to be enabled by most installations. This vulnerability pertains to the user context used in the default-user-settings-flow, /api/v3/flows/instances/default-user-settings-flow/execute/. This issue has been fixed in versions 2022.10.4 and 2022.11.4.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2022-46172?
CVE-2022-46172 is a medium-severity vulnerability. It was published on December 28, 2022 and has a CVSS 3.1 base score of 6.4 (MEDIUM).
How severe is CVE-2022-46172?
This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2022-46172?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2022-46172?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-46172 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2022
View all- 6.9CVE-2021-41236
OroPlatform is a PHP Business Application Platform. In affected versions the email template preview
View details - 6.9CVE-2022-22552
Dell EMC AppSync versions 3.9 to 4.3 contain a clickjacking vulnerability in AppSync. A remote unaut
View details - 6.9CVE-2022-22566
Select Dell Client Commercial and Consumer platforms contain a pre-boot direct memory access (DMA) v
View details - 6.9CVE-2021-34359
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running Proxy Ser
View details - 6.9CVE-2022-29813
In JetBrains IntelliJ IDEA before 2022.1 local code execution via custom Pandoc path was possible
View details - 6.9CVE-2022-29814
In JetBrains IntelliJ IDEA before 2022.1 local code execution via HTML descriptions in custom JSON s
View details - 6.9CVE-2022-29815
In JetBrains IntelliJ IDEA before 2022.1 local code execution via workspace settings was possible
View details - 6.9CVE-2022-29819
In JetBrains IntelliJ IDEA before 2022.1 local code execution via links in Quick Documentation was p
View details - 6.9CVE-2022-29821
In JetBrains Rider before 2022.1 local code execution via links in ReSharper Quick Documentation was
View details - 6.9CVE-2022-25842
All versions of package com.alibaba.oneagent:one-java-agent-plugin are vulnerable to Arbitrary File
View details - 6.9CVE-2022-1803
Improper Restriction of Rendered UI Layers or Frames in GitHub repository polonel/trudesk prior to 1
View details - 6.9CVE-2022-2503
Dm-verity is used for extending root-of-trust to root filesystems. LoadPin builds on this property t
View details
