CVE-2023-37275
3.1 · LOWAuto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model.
Overview
CVE-2023-37275 is a low-severity vulnerability. It was published on July 13, 2023 and has a CVSS 3.1 base score of 3.1 (LOW).
This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
Technical description
Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. The Auto-GPT command line UI makes heavy use of color-coded print statements to signify different types of system messages to the user, including messages that are crucial for the user to review and control which commands should be executed. Before v0.4.3, it was possible for a malicious external resource (such as a website browsed by Auto-GPT) to cause misleading messages to be printed to the console by getting the LLM to regurgitate JSON encoded ANSI escape sequences (`\u001b[`). These escape sequences were JSON decoded and printed to the console as part of the model's "thinking process". The issue has been patched in release version 0.4.3.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2023-37275?
CVE-2023-37275 is a low-severity vulnerability. It was published on July 13, 2023 and has a CVSS 3.1 base score of 3.1 (LOW).
How severe is CVE-2023-37275?
This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2023-37275?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2023-37275?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-37275 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related LOW CVEs from 2023
View all- 3.9CVE-2022-22732
A CWE-668: Exposure of Resource to Wrong Sphere vulnerability exists that could cause all remote dom
View details - 3.9CVE-2022-3083
All versions of Landis+Gyr E850 (ZMQ200) are vulnerable to CWE-784: Reliance on Cookies Without Vali
View details - 3.9CVE-2022-34376
Dell PowerEdge BIOS and Dell Precision BIOS contain an improper input validation vulnerability. A
View details - 3.9CVE-2023-0808
A vulnerability was found in Deye/Revolt/Bosswerk Inverter MW3_15U_5406_1.47/MW3_15U_5406_1.471. It
View details - 3.9CVE-2023-23939
Azure/setup-kubectl is a GitHub Action for installing Kubectl. This vulnerability only impacts versi
View details - 3.9CVE-2023-22591
IBM Robotic Process Automation 21.0.1 through 21.0.7 and 23.0.0 through 23.0.1 could allow a user wi
View details - 3.9CVE-2022-1230
This vulnerability allows local attackers to execute arbitrary code on affected installations of Sam
View details - 3.9CVE-2023-30544
Kiwi TCMS is an open source test management system. In versions of Kiwi TCMS prior to 12.2, users we
View details - 3.9CVE-2023-30624
Wasmtime is a standalone runtime for WebAssembly. Prior to versions 6.0.2, 7.0.1, and 8.0.1, Wasmtim
View details - 3.9CVE-2021-46762
Insufficient input validation in the SMU may allow an attacker to corrupt SMU SRAM potentially leadi
View details - 3.9CVE-2023-23910
Out-of-bounds write for some Intel(R) Trace Analyzer and Collector software before version 2021.8.0
View details - 3.9CVE-2023-30571
Libarchive through 3.6.2 can cause directories to have world-writable permissions. The umask() call
View details
