Menu

Star on GitHub · 3.3k

CVE-2023-41332

3.5 · LOW

Cilium is a networking, observability, and security solution with an eBPF-based dataplane.

Published Sep 27, 2023CWE-755EPSS 0.51%

Overview

CVE-2023-41332 is a low-severity vulnerability. It was published on September 27, 2023 and has a CVSS 3.1 base score of 3.5 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with `policy.cilium.io/proxy-visibility` annotations (in Cilium >= v1.13) or `io.cilium.proxy-visibility` annotations (in Cilium <= v1.12) causes the Cilium agent to segfault on the node to which the workload is assigned. Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks. This issue has been resolved in Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users unable to upgrade can avoid this denial of service attack by enablin

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2023-41332?

CVE-2023-41332 is a low-severity vulnerability. It was published on September 27, 2023 and has a CVSS 3.1 base score of 3.5 (LOW).

How severe is CVE-2023-41332?

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2023-41332?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2023-41332?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-41332 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2023

View all
LiveWatch live →