Menu

Star on GitHub · 3.3k

CVE-2023-42419

3.8 · LOW

Maintenance Server, in Cybellum's QCOW air-gapped distribution (China Edition), versions 2.15.5 through 2.27, was compiled with a hard-coded private cryptographic key.

Published Mar 5, 2024EPSS 0.14%

Overview

CVE-2023-42419 is a low-severity vulnerability. It was published on March 5, 2024 and has a CVSS 3.1 base score of 3.8 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.8, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

Maintenance Server, in Cybellum's QCOW air-gapped distribution (China Edition), versions 2.15.5 through 2.27, was compiled with a hard-coded private cryptographic key.

An attacker with administrative privileges & access to the air-gapped server could potentially use this key to run commands on the server.

The issue was resolved in version 2.28.

Earlier versions, including all Cybellum 1.x versions, and distributions for the rest of the world remain unaffected.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2023-42419?

CVE-2023-42419 is a low-severity vulnerability. It was published on March 5, 2024 and has a CVSS 3.1 base score of 3.8 (LOW).

How severe is CVE-2023-42419?

This vulnerability has a CVSS 3.1 base score of 3.8, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2023-42419?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2023-42419?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-42419 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2023

View all
LiveWatch live →