CVE-2024-22202
5.7 · MEDIUMphpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases.
Overview
CVE-2024-22202 is a medium-severity vulnerability. It was published on February 5, 2024 and has a CVSS 3.1 base score of 5.7 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. phpMyFAQ's user removal page allows an attacker to spoof another user's detail, and in turn make a compelling phishing case for removing another user's account. The front-end of this page doesn't allow changing the form details, an attacker can utilize a proxy to intercept this request and submit other data. Upon submitting this form, an email is sent to the administrator informing them that this user wants to delete their account. An administrator has no way of telling the difference between the actual user wishing to delete their account or the attacker issuing this for an account they do not control. This issue has been patched in version 3.2.5.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2024-22202?
CVE-2024-22202 is a medium-severity vulnerability. It was published on February 5, 2024 and has a CVSS 3.1 base score of 5.7 (MEDIUM).
How severe is CVE-2024-22202?
This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2024-22202?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2024-22202?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-22202 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2024
View all- 6.9CVE-2023-3726
OCSInventory allow stored email template with special characters that lead to a Stored cross-site Sc
View details - 6.9CVE-2023-51719
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51720
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51721
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51722
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51723
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51724
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51725
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51726
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51727
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51728
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details - 6.9CVE-2023-51729
This vulnerability exist in Skyworth Router CM5100, version 4.1.1.24, due to insufficient validation
View details
