Menu

Star on GitHub · 3.3k

CVE-2024-22408

7.6 · HIGH

Shopware is an open headless commerce platform.

Published Jan 16, 2024CWE-918EPSS 0.37%

Overview

CVE-2024-22408 is a high-severity vulnerability. It was published on January 16, 2024 and has a CVSS 3.1 base score of 7.6 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Shopware is an open headless commerce platform. The implemented Flow Builder functionality in the Shopware application does not adequately validate the URL used when creating the “call webhook” action. This enables malicious users to perform web requests to internal hosts. This issue has been fixed in the Commercial Plugin release 6.5.7.4 or with the Security Plugin. For installations with Shopware 6.4 the Security plugin is recommended to be installed and up to date. For older versions of 6.4 and 6.5 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-22408?

CVE-2024-22408 is a high-severity vulnerability. It was published on January 16, 2024 and has a CVSS 3.1 base score of 7.6 (HIGH).

How severe is CVE-2024-22408?

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2024-22408?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-22408?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-22408 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2024

View all
LiveWatch live →