Menu

Star on GitHub · 3.3k

CVE-2024-32882

2.7 · LOW

Wagtail is an open source content management system built on Django.

Published May 2, 2024CWE-280EPSS 0.48%

Overview

CVE-2024-32882 is a low-severity vulnerability. It was published on May 2, 2024 and has a CVSS 3.1 base score of 2.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 2.7, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Wagtail is an open source content management system built on Django. In affected versions if a model has been made available for editing through the `wagtail.contrib.settings` module or `ModelViewSet`, and the `permission` argument on `FieldPanel` has been used to further restrict access to one or more fields of the model, a user with edit permission over the model but not the specific field can craft an HTTP POST request that bypasses the permission check on the individual field, allowing them to update its value. This vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, or by a user who has not been granted edit access to the model in question. The editing interfaces for pages and snippets are also unaffected. Patched versions have been released as Wagtail 6.0.3 and 6.1. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability as follo

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-32882?

CVE-2024-32882 is a low-severity vulnerability. It was published on May 2, 2024 and has a CVSS 3.1 base score of 2.7 (LOW).

How severe is CVE-2024-32882?

This vulnerability has a CVSS 3.1 base score of 2.7, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2024-32882?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-32882?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-32882 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2024

View all
LiveWatch live →