Menu

Star on GitHub · 3.4k

CVE-2025-15540

8.8 · HIGH

"Functions" module in Raytha CMS allows privileged users to write custom code to add functionality to application.

Published Mar 16, 2026raythaCWE-94EPSS 0.50%

Overview

CVE-2025-15540 is a high-severity vulnerability affecting raytha raytha. It was published on March 16, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

"Functions" module in Raytha CMS allows privileged users to write custom code to add functionality to application. Due to a lack of sandboxing or access restrictions, JavaScript code executed through Raytha’s “functions” feature can instantiate .NET components and perform arbitrary operations within the application’s hosting environment.

This issue was fixed in version 1.4.6.

Remediation

Check the references section for vendor advisories and patches from raytha. Update raytha to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
raytharaytha>= 0, < 1.4.6Affected

Frequently asked questions

What is CVE-2025-15540?

CVE-2025-15540 is a high-severity vulnerability affecting raytha raytha. It was published on March 16, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2025-15540?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-15540?

Check the references section for vendor advisories and patches from raytha. Update raytha to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-15540?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-15540 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2025

View all
Watch the demo →