Menu

Star on GitHub · 3.3k

CVE-2025-24014

4.2 · MEDIUM

Vim is an open source, command line text editor.

Published Jan 20, 2025CWE-787EPSS 0.28%

Overview

CVE-2025-24014 is a medium-severity vulnerability. It was published on January 20, 2025 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

Vim is an open source, command line text editor. A segmentation fault was found in Vim before 9.1.1043. In silent Ex mode (-s -e), Vim typically doesn't show a screen and just operates silently in batch mode. However, it is still possible to trigger the function that handles the scrolling of a gui version of Vim by feeding some binary characters to Vim. The function that handles the scrolling however may be triggering a redraw, which will access the ScreenLines pointer, even so this variable hasn't been allocated (since there is no screen). This vulnerability is fixed in 9.1.1043.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-24014?

CVE-2025-24014 is a medium-severity vulnerability. It was published on January 20, 2025 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

How severe is CVE-2025-24014?

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-24014?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-24014?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-24014 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
LiveWatch live →