Menu

Star on GitHub · 3.4k

CVE-2025-31991

6.8 · MEDIUM

Rate Limiting for attempting a user login is not being properly enforced, making HCL DevOps Velocity susceptible to brute-force attacks past the unsuccessful login attempt limit.

Published Apr 13, 2026hcltechCWE-307EPSS 0.23%

Overview

CVE-2025-31991 is a medium-severity vulnerability affecting hcltech devops_velocity. It was published on April 13, 2026 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Rate Limiting for attempting a user login is not being properly enforced, making HCL DevOps Velocity susceptible to brute-force attacks past the unsuccessful login attempt limit.  This vulnerability is fixed in 5.1.7.

Remediation

Check the references section for vendor advisories and patches from hcltech. Update devops_velocity to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
hcltechdevops_velocity>= 0, < 5.1.7Affected

Frequently asked questions

What is CVE-2025-31991?

CVE-2025-31991 is a medium-severity vulnerability affecting hcltech devops_velocity. It was published on April 13, 2026 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

How severe is CVE-2025-31991?

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-31991?

Check the references section for vendor advisories and patches from hcltech. Update devops_velocity to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-31991?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-31991 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
Watch the demo →