Menu

Star on GitHub · 3.4k

CVE-2025-32015

6.7 · MEDIUM

FreshRSS is a self-hosted RSS feed aggregator.

Published Jun 4, 2025CWE-79EPSS 0.49%

Overview

CVE-2025-32015 is a medium-severity vulnerability. It was published on June 4, 2025 and has a CVSS 3.1 base score of 6.7 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

FreshRSS is a self-hosted RSS feed aggregator. Prior to version 1.26.2, HTML is sanitized improperly inside the `<iframe srcdoc>` attribute, which leads to cross-site scripting (XSS) by loading an attacker's UserJS inside `<script src>`. In order to execute the attack, the attacker needs to control one of the victim's feeds and have an account on the FreshRSS instance that the victim is using. An attacker can gain access to the victim's account by exploiting this vulnerability. If the victim is an admin it would be possible to delete all users (cause damage) or execute arbitrary code on the server by modifying the update URL using fetch() via the XSS. Version 1.26.2 contains a patch for the issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-32015?

CVE-2025-32015 is a medium-severity vulnerability. It was published on June 4, 2025 and has a CVSS 3.1 base score of 6.7 (MEDIUM).

How severe is CVE-2025-32015?

This vulnerability has a CVSS 3.1 base score of 6.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-32015?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-32015?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-32015 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
Watch the demo →