Menu

Star on GitHub · 3.4k

CVE-2025-32957

8.7 · HIGH

baserCMS is a website development framework.

Published Mar 31, 2026basercmsCWE-434EPSS 0.59%

Overview

CVE-2025-32957 is a high-severity vulnerability affecting basercms basercms. It was published on March 31, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

baserCMS is a website development framework. Prior to version 5.2.3, the application's restore function allows users to upload a .zip file, which is then automatically extracted. A PHP file inside the archive is included using require_once without validating or restricting the filename. An attacker can craft a malicious PHP file within the zip and achieve arbitrary code execution when it is included. This issue has been patched in version 5.2.3.

Remediation

Check the references section for vendor advisories and patches from basercms. Update basercms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
basercmsbasercms>= 0, < 5.2.3Affected

Frequently asked questions

What is CVE-2025-32957?

CVE-2025-32957 is a high-severity vulnerability affecting basercms basercms. It was published on March 31, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

How severe is CVE-2025-32957?

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-32957?

Check the references section for vendor advisories and patches from basercms. Update basercms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-32957?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-32957 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2025

View all
Watch the demo →