Menu

Star on GitHub · 3.3k

CVE-2025-67510

9.4 · CRITICAL

Neuron is a PHP framework for creating and orchestrating AI Agents.

Published Dec 10, 2025CWE-250EPSS 0.41%

Overview

CVE-2025-67510 is a critical-severity vulnerability. It was published on December 10, 2025 and has a CVSS 3.1 base score of 9.4 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.4, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Neuron is a PHP framework for creating and orchestrating AI Agents. In versions 2.8.11 and below, the MySQLWriteTool executes arbitrary SQL provided by the caller using PDO::prepare() + execute() without semantic restrictions. This is consistent with the name (“write tool”), but in an LLM/agent context it becomes a high-risk capability: prompt injection or indirect prompt manipulation can cause execution of destructive queries such as DROP TABLE, TRUNCATE, DELETE, ALTER, or privilege-related statements (subject to DB permissions). Deployments that expose an agent with MySQLWriteTool enabled to untrusted input and/or run the tool with a DB user that has broad privileges are impacted. This issue is fixed in version 2.8.12.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-67510?

CVE-2025-67510 is a critical-severity vulnerability. It was published on December 10, 2025 and has a CVSS 3.1 base score of 9.4 (CRITICAL).

How severe is CVE-2025-67510?

This vulnerability has a CVSS 3.1 base score of 9.4, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-67510?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-67510?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-67510 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2025

View all
LiveWatch live →