Menu

Star on GitHub · 3.4k

CVE-2026-100542

3.1 · LOW

OpenClaw (npm package 'openclaw') versions >= 2026.5.28 and < 2026.8.1 mishandle archive listings in the tar.bz2 skill installer: bounded command-output suffixes were treated as complete listings o…

Published Sep 26, 2026CWE-400EPSS 0.26%

Overview

CVE-2026-100542 is a low-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

OpenClaw (npm package 'openclaw') versions >= 2026.5.28 and < 2026.8.1 mishandle archive listings in the tar.bz2 skill installer: bounded command-output suffixes were treated as complete listings of the archive. A crafted .tar.bz2/.tbz2 skill archive can push prohibited entries out of both retained listings so that entry-count and size checks pass, and the archive is then extracted in full. If an operator approves installation of such a malicious or compromised skill archive, over-limit files or entry counts are persisted in the skill tools directory, consuming disk space or inodes. The issue bypasses OpenClaw's extraction budgets but does not by itself execute archive contents. Fixed in 2026.8.1.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-100542?

CVE-2026-100542 is a low-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

How severe is CVE-2026-100542?

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-100542?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100542?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100542 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach