Menu

Star on GitHub · 3.4k

CVE-2026-100579

7.6 · HIGH

OpenClaw (npm package 'openclaw') before 2026.7.1 incorrectly trusts requester provenance in message.action.

Published Sep 26, 2026CWE-639EPSS 0.23%

Overview

CVE-2026-100579 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 7.6 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

OpenClaw (npm package 'openclaw') before 2026.7.1 incorrectly trusts requester provenance in message.action. In identity-bearing Gateway deployments (authentication modes that honor caller identity and narrower operator scopes), a write-scoped caller can supply another sender's identifier to the channel authorization checks and invoke a channel action under that spoofed requester identity, reaching operations the channel adapter would have denied to the real caller. Practical impact depends on the enabled channel, the action, and the target account's permissions. Shared-secret token and password callers are full trusted operators under OpenClaw's security model and are out of scope. The issue is fixed in 2026.7.1; as a workaround, restrict message.action to administrators and disable sensitive channel actions that rely on requester identity.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-100579?

CVE-2026-100579 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 7.6 (HIGH).

How severe is CVE-2026-100579?

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-100579?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100579?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100579 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →