Menu

Star on GitHub · 3.4k

CVE-2026-100691

5.4 · MEDIUM

Hugo versions 0.75.0 through 0.165.x contain a stored cross-site scripting vulnerability: the syntax highlighter does not escape the `lineAnchors` option before passing it to Chroma, which writes t…

Published Sep 26, 2026gohugoCWE-79EPSS 0.17%

Overview

CVE-2026-100691 is a medium-severity vulnerability affecting gohugo hugo. It was published on September 26, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Hugo versions 0.75.0 through 0.165.x contain a stored cross-site scripting vulnerability: the syntax highlighter does not escape the `lineAnchors` option before passing it to Chroma, which writes the value verbatim into the `id` and `href` attributes of the generated line-number markup. A crafted `lineAnchors` value supplied as a Markdown code fence attribute (or passed to the `highlight` template function) results in unescaped HTML in the rendered page, allowing arbitrary JavaScript to execute in the browsers of visitors to the generated site. This affects sites that build and publish Markdown from untrusted contributors; Hugo's security model otherwise considers content trusted input. Fixed in 0.166.0, where the `lineAnchors` value is HTML-escaped before being passed to Chroma.

Remediation

Check the references section for vendor advisories and patches from gohugo. Update hugo to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
gohugohugo>= 0.75.0, < 0.166.0Affected

Frequently asked questions

What is CVE-2026-100691?

CVE-2026-100691 is a medium-severity vulnerability affecting gohugo hugo. It was published on September 26, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

How severe is CVE-2026-100691?

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-100691?

Check the references section for vendor advisories and patches from gohugo. Update hugo to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100691?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100691 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →