Menu

Star on GitHub · 3.4k

CVE-2026-100716

9.9 · CRITICAL

Froxlor is a server administration panel.

Published Sep 26, 2026CWE-59EPSS 0.46%

Overview

CVE-2026-100716 is a critical-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Froxlor is a server administration panel. In versions 2.3.10 and earlier, the customer data-export (DataDump) cron fails to validate intermediate path components of the export destination: Froxlor\FileDir::makeCorrectDir() contains an off-by-one in its path-component walk that skips the first segment below the customer home directory, and the guard in ExportCron.php checks only the final component with is_link(). An authenticated customer whose account has the export feature enabled can schedule an export into a genuine subdirectory of their own webspace, then replace an intermediate path component with a symlink before the root-owned cron runs. The cron's `chown -R` then recursively changes ownership of the linked directory tree — for example /etc — to the customer's UID, yielding host root and cross-tenant compromise. Exploitation is deterministic and requires no race. This is an incomplete fix of GHSA-75h4-... The issue is fixed in Froxlor 2.3.12.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-100716?

CVE-2026-100716 is a critical-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

How severe is CVE-2026-100716?

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-100716?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100716?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100716 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach