Menu

Star on GitHub · 3.4k

CVE-2026-102826

8.1 · HIGH

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript.

Published Sep 29, 2026simple-git_projectCWE-77EPSS 0.46%

Overview

CVE-2026-102826 is a high-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin does not completely reject configuration includes supplied through customArgs to git.clone(). The missing include.path classification permits Git to load an attacker-controlled configuration file, and the initial remediation does not cover includeIf.<condition>.path, allowing the same file-loading primitive through a conditional include. A loaded configuration can set an executable Git option such as core.sshCommand, which Git invokes during the clone operation with the privileges of the Node.js process. Exploitation requires the application to pass attacker-influenced custom arguments and requires an attacker-controlled file that the process can read. This issue is fixed in 4.0.0.

Remediation

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
simple-git_projectsimple-git>= 0, < 4.0.0Affected

Frequently asked questions

What is CVE-2026-102826?

CVE-2026-102826 is a high-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-102826?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-102826?

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-102826?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-102826 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →