Menu

Star on GitHub · 3.4k

CVE-2026-102828

9.8 · CRITICAL

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript.

Published Sep 29, 2026simple-git_projectCWE-78EPSS 0.37%

Overview

CVE-2026-102828 is a critical-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 9.8 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.8, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Remediation

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
simple-git_projectsimple-git>= 3.15.0, < 4.0.1Affected

Frequently asked questions

What is CVE-2026-102828?

CVE-2026-102828 is a critical-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 9.8 (CRITICAL).

How severe is CVE-2026-102828?

This vulnerability has a CVSS 3.1 base score of 9.8, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-102828?

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-102828?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-102828 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach