Menu

Star on GitHub · 3.4k

CVE-2026-103412

8.8 · HIGH

Improper limitation of a pathname to a restricted directory ('path traversal') vulnerability in Apache Camel Karavan.

Published Oct 9, 2026CWE-22EPSS 0.52%

Overview

CVE-2026-103412 is a high-severity vulnerability. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Improper limitation of a pathname to a restricted directory ('path traversal') vulnerability in Apache Camel Karavan.

A project file name supplied through the project file API was used verbatim as a path segment when the project was written to the working copy for a Git commit, so a name containing `../` sequences caused the file content to be written outside the project directory, to any location writable by the Karavan process. An authenticated user of any role could use this to overwrite application configuration or files on the application classpath and so execute code in the Karavan container.

This issue affects Apache Camel Karavan: from 3.18.0 before 4.22.1.

Users are recommended to upgrade to version 4.22.1, which fixes the issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-103412?

CVE-2026-103412 is a high-severity vulnerability. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-103412?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-103412?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-103412?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-103412 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →