Menu

Star on GitHub · 3.4k

CVE-2026-104140

6.1 · MEDIUM

QGIS is a free, open source, cross-platform geographic information system.

Published Oct 12, 2026CWE-79EPSS 0.24%

Overview

CVE-2026-104140 is a medium-severity vulnerability. It was published on October 12, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

QGIS is a free, open source, cross-platform geographic information system. Prior to 3.44.12 and 4.0.0 through 4.2.3, QGIS Server renders feature data in WFS3 (OGC API Features) HTML responses without HTML escaping. Attacker-controlled feature.properties values from a published writable vector layer reach resources/server/api/ogc/templates/wfs3/getFeatures.html through QgsServerOgcApiHandler::htmlDump and the if_nullptr_null_str callback. A user who opens an items HTML page can execute stored markup or script in the QGIS Server origin, which can expose the viewer's session data or issue authenticated requests with the viewer's privileges. This issue is fixed in version 3.44.12.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-104140?

CVE-2026-104140 is a medium-severity vulnerability. It was published on October 12, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

How severe is CVE-2026-104140?

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-104140?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-104140?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-104140 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →