Menu

Star on GitHub · 3.4k

CVE-2026-104714

8.8 · HIGH

Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts.

Published Oct 5, 2026apacheCWE-362EPSS 0.53%

Overview

CVE-2026-104714 is a high-severity vulnerability affecting apache struts. It was published on October 5, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts. Where a localized message formats a date or time argument, the formatter retained for that message by the application-wide text provider is used by concurrently served requests without isolation, so a value belonging to one user can appear in another user's response, or the rendering can fail and surface as a server error. Applications whose localized messages format no date or time arguments are not affected.

This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update struts to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachestruts2.0.0Affected

Frequently asked questions

What is CVE-2026-104714?

CVE-2026-104714 is a high-severity vulnerability affecting apache struts. It was published on October 5, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-104714?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-104714?

Check the references section for vendor advisories and patches from apache. Update struts to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-104714?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-104714 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →