Menu

Star on GitHub · 3.4k

CVE-2026-105263

4.7 · MEDIUM

A security flaw has been discovered in Shaarli up to 0.16.3.

Published Oct 5, 2026CWE-918EPSS 0.23%

Overview

CVE-2026-105263 is a medium-severity vulnerability. It was published on October 5, 2026 and has a CVSS 3.1 base score of 4.7 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A security flaw has been discovered in Shaarli up to 0.16.3. The affected element is the function MetadataController of the file application/front/controller/admin/MetadataController.php of the component Admin Metadata Endpoint. Performing a manipulation of the argument url results in server-side request forgery. The attack may be initiated remotely. Upgrading to version 0.16.4 is sufficient to fix this issue. The patch is named 8ca4de8e7c932a684481f5fbb1229fe16de1f4d2. It is advisable to upgrade the affected component.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-105263?

CVE-2026-105263 is a medium-severity vulnerability. It was published on October 5, 2026 and has a CVSS 3.1 base score of 4.7 (MEDIUM).

How severe is CVE-2026-105263?

This vulnerability has a CVSS 3.1 base score of 4.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-105263?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105263?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105263 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →