Menu

Star on GitHub · 3.4k

CVE-2026-105746

2.2 · LOW

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem.

Published Oct 5, 2026doclingCWE-668EPSS 0.22%

Overview

CVE-2026-105746 is a low-severity vulnerability affecting docling docling. It was published on October 5, 2026 and has a CVSS 3.1 base score of 2.2 (LOW).

This vulnerability has a CVSS 3.1 base score of 2.2, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.83.0 until 2.131.0, the KServeV2OcrModel class defined in docling/models/stages/ocr/kserve_v2_ocr_model.py sends page images to its configured endpoint without checking the pipeline_options.enable_remote_services setting, even when the caller sets that policy control to false. The StandardPdfPipeline._make_ocr_model method also fails to pass the flag into the OCR factory, allowing remote OCR processing in configurations that rely on remote services being disabled. The destination is configured by the caller rather than selected by an attacker. This issue is fixed in 2.131.0.

Remediation

Check the references section for vendor advisories and patches from docling. Update docling to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
doclingdocling>= 2.83.0, < 2.131.0Affected

Frequently asked questions

What is CVE-2026-105746?

CVE-2026-105746 is a low-severity vulnerability affecting docling docling. It was published on October 5, 2026 and has a CVSS 3.1 base score of 2.2 (LOW).

How severe is CVE-2026-105746?

This vulnerability has a CVSS 3.1 base score of 2.2, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-105746?

Check the references section for vendor advisories and patches from docling. Update docling to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105746?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105746 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach