Menu

Star on GitHub · 3.4k

CVE-2026-105857

10.0 · CRITICAL

Payload is a free and open source headless content management system.

Published Oct 6, 2026payloadcmsCWE-94EPSS 0.43%

Overview

CVE-2026-105857 is a critical-severity vulnerability affecting payloadcms payload. It was published on October 6, 2026 and has a CVSS 3.1 base score of 10.0 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 10.0, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Remediation

Check the references section for vendor advisories and patches from payloadcms. Update payload to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
payloadcmspayload>= 0, < 3.90.0Affected

Frequently asked questions

What is CVE-2026-105857?

CVE-2026-105857 is a critical-severity vulnerability affecting payloadcms payload. It was published on October 6, 2026 and has a CVSS 3.1 base score of 10.0 (CRITICAL).

How severe is CVE-2026-105857?

This vulnerability has a CVSS 3.1 base score of 10.0, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-105857?

Check the references section for vendor advisories and patches from payloadcms. Update payload to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105857?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105857 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach