Menu

Star on GitHub · 3.4k

CVE-2026-10591

8.8 · HIGH

Insufficient access control restrictions in the file write tool in Amazon Kiro IDE before version 0.11 might allow remote unauthenticated actors to execute arbitrary commands via crafted instructio…

Published Jun 2, 2026amazonCWE-732EPSS 0.83%

Overview

CVE-2026-10591 is a high-severity vulnerability affecting amazon kiro_ide. It was published on June 2, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Insufficient access control restrictions in the file write tool in Amazon Kiro IDE before version 0.11 might allow remote unauthenticated actors to execute arbitrary commands via crafted instructions that cause writes to execution-sensitive paths (such as .vscode/tasks.json), enabling auto-execution on folder open.

To remediate this issue, users should upgrade to Kiro IDE version 0.11 or later.

Remediation

Check the references section for vendor advisories and patches from amazon. Update kiro_ide to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
amazonkiro_ide>= 0, < 0.11Affected

Frequently asked questions

What is CVE-2026-10591?

CVE-2026-10591 is a high-severity vulnerability affecting amazon kiro_ide. It was published on June 2, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-10591?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-10591?

Check the references section for vendor advisories and patches from amazon. Update kiro_ide to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-10591?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-10591 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →