Menu

Star on GitHub · 3.4k

CVE-2026-106151

5.4 · MEDIUM

In Progress® Kendo® UI for jQuery versions starting with 2012.2.710 and prior to 2026.3.1015, the Validator decodes validation messages from data-msg-* attributes and parses the resulting text as H…

Published Oct 15, 2026progressCWE-80EPSS 0.18%

Overview

CVE-2026-106151 is a medium-severity vulnerability affecting progress kendo_ui. It was published on October 15, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

In Progress® Kendo® UI for jQuery versions starting with 2012.2.710 and prior to 2026.3.1015, the Validator decodes validation messages from data-msg-* attributes and parses the resulting text as HTML. An attacker who can modify a validation message can cause HTML that was correctly escaped in the page attribute to become active markup, including event handlers, when the user triggers validation. Successful exploitation can execute JavaScript in a user's browser and compromise the confidentiality and integrity of data accessible to the affected application. This issue is fixed in version 2026.3.1015.

Remediation

Check the references section for vendor advisories and patches from progress. Update kendo_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
progresskendo_ui>= 2012.2.710, < 2026.3.1015Affected

Frequently asked questions

What is CVE-2026-106151?

CVE-2026-106151 is a medium-severity vulnerability affecting progress kendo_ui. It was published on October 15, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

How severe is CVE-2026-106151?

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106151?

Check the references section for vendor advisories and patches from progress. Update kendo_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106151?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106151 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →