Menu

Star on GitHub · 3.4k

CVE-2026-106456

4.8 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-863EPSS 0.24%

Overview

CVE-2026-106456 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-proxy-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-proxy-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-proxy-backend>= 0.5.0, < 0.6.18Affected
linuxfoundationbackstage>= 1.28.0, < 1.55.0Affected

Frequently asked questions

What is CVE-2026-106456?

CVE-2026-106456 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-proxy-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

How severe is CVE-2026-106456?

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-106456?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-proxy-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106456?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106456 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →