Menu

Star on GitHub · 3.4k

CVE-2026-106460

6.8 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-287EPSS 0.31%

Overview

CVE-2026-106460 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-auth-node. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. From 0.3.0 until 0.6.15 and 0.7.5, the @backstage/plugin-auth-node package did not consistently honor explicit negative email verification during shared OAuth profile normalization. The affected paths include a selected profile email marked verified: false, a matching raw provider email marked email_verified: false, and an email obtained only from an ID token marked email_verified: false. Exploitation requires an admitted identity-provider user who can supply or change an unverified email and a deployment that uses the selected profile email to resolve catalog identities. The verification metadata must apply to the selected email; an absent email_verified claim alone is not affected. In an affected configuration, the user may assume another catalog identity and obtain its associated access and permissions. This issue is fixed in versions 0.6.15 and 0.7.5.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-auth-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-auth-node>= 0.3.0, < 0.6.15Affected
linuxfoundationbackstage>= 0.4.0, < 0.5.15Affected

Frequently asked questions

What is CVE-2026-106460?

CVE-2026-106460 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-auth-node. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

How severe is CVE-2026-106460?

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106460?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-auth-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106460?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106460 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →