Menu

Star on GitHub · 3.4k

CVE-2026-106463

5.4 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-863EPSS 0.17%

Overview

CVE-2026-106463 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-catalog-backend-module-gitlab. It was published on October 6, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 0.8.7, the @backstage/plugin-catalog-backend-module-gitlab package is affected by improper authorization in gitlab organizational user ingestion. Deployments that enable GitLab organization event ingestion and rely on scoped catalog users as an access boundary may admit an unintended catalog identity. Depending on sign-in and permission configuration, this may allow unauthorized access with the permissions of a standard authenticated user. This issue is fixed in version 0.8.7.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-catalog-backend-module-gitlab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-catalog-backend-module-gitlab>= 0, < 0.8.7Affected
linuxfoundationbackstage>= 0, < 1.54.6Affected

Frequently asked questions

What is CVE-2026-106463?

CVE-2026-106463 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-catalog-backend-module-gitlab. It was published on October 6, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

How severe is CVE-2026-106463?

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106463?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-catalog-backend-module-gitlab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106463?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106463 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →