Menu

Star on GitHub · 3.4k

CVE-2026-106489

6.5 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-22EPSS 0.29%

Overview

CVE-2026-106489 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-techdocs-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 2.2.4, the @backstage/plugin-techdocs-backend package is affected by improper authorization enforcement for techdocs static content. An authenticated user with access to one TechDocs documentation site could craft a URL able to read documentation belonging to a different entity. This only affects deployments using the external TechDocs builder with an external storage provider (S3, GCS, etc.) and the permission framework enabled. Instances that do not use the permission framework are unaffected, since TechDocs content is visible to all authenticated users by design. This issue is fixed in version 2.2.4.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-techdocs-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-techdocs-backend>= 0, < 2.2.4Affected
linuxfoundationbackstage>= 0, < 1.54.6Affected

Frequently asked questions

What is CVE-2026-106489?

CVE-2026-106489 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-techdocs-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

How severe is CVE-2026-106489?

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106489?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-techdocs-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106489?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106489 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →