Menu

Star on GitHub · 3.4k

CVE-2026-106500

8.5 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-59EPSS 0.34%

Overview

CVE-2026-106500 is a high-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by improper task state validation in scaffolder backend. An authenticated user with permission to create and access Scaffolder tasks may, under specific timing and deployment conditions, affect files accessible to the Backstage backend. If backend application files are writable, the confidentiality, integrity, and availability of the backend may be compromised. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-scaffolder-backend>= 0, < 3.3.1Affected
linuxfoundationbackstage>= 0, < 1.49.6Affected

Frequently asked questions

What is CVE-2026-106500?

CVE-2026-106500 is a high-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

How severe is CVE-2026-106500?

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106500?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106500?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106500 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →