Menu

Star on GitHub · 3.4k

CVE-2026-106504

6.5 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-532EPSS 0.26%

Overview

CVE-2026-106504 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder task logs. An authenticated user who can create and read scaffolder tasks may be able to observe sensitive values in task logs in deployments with restrictive action permissions and affected templates. Exploitation requires a denied action whose input contains such a value. This issue is fixed in version 4.1.0.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-scaffolder-backend>= 0, < 4.1.0Affected
linuxfoundationbackstage>= 0, < 1.54.6Affected

Frequently asked questions

What is CVE-2026-106504?

CVE-2026-106504 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

How severe is CVE-2026-106504?

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106504?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106504?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106504 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →