Menu

Star on GitHub · 3.4k

CVE-2026-106558

8.8 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 7, 2026linuxfoundationCWE-502EPSS 0.47%

Overview

CVE-2026-106558 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-techdocs-node. It was published on October 7, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 1.14.8, 1.15.6, and 2.0.1, the @backstage/plugin-techdocs-node package improperly validated mapping-style markdown_extensions configuration. An authenticated attacker who can register or influence an SCM-backed documentation source may bypass TechDocs sanitization and cause Python objects to be imported and instantiated in the generator runtime, leading to arbitrary code execution. Earlier fixes in versions 1.14.6 and 1.15.4 did not fully address the supported mapping representation of markdown_extensions. Impact is greatest when documentation generation runs with backend credentials, filesystem access, or internal network access. This issue is fixed in versions 1.14.8, 1.15.6, and 2.0.1.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-techdocs-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage_plugin-techdocs-node>= 0, < 1.14.8Affected
linuxfoundationbackstage>= 0, < 1.50.7Affected

Frequently asked questions

What is CVE-2026-106558?

CVE-2026-106558 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-techdocs-node. It was published on October 7, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-106558?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106558?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-techdocs-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106558?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106558 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →