Menu

Star on GitHub · 3.4k

CVE-2026-107805

7.5 · HIGH

Nginx UI is a web user interface for the Nginx web server.

Published Oct 9, 2026nginxuiCWE-400EPSS 0.47%

Overview

CVE-2026-107805 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Nginx UI is a web user interface for the Nginx web server. From 2.5.0 until 2.6.0, the node-signature authentication path performs temporary file staging of an attacker-controlled request body and synchronizes it before validating the body digest and cryptographic signature. An unauthenticated remote client that can reach the API and provide syntactically valid signature metadata can consume temporary filesystem capacity, disk input and output, and request-processing resources before rejection. The issue affects availability and does not bypass authentication or provide confidentiality or integrity impact. This issue is fixed in version 2.6.0.

Remediation

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
nginxuinginx_ui>= 2.5.0, < 2.6.0Affected

Frequently asked questions

What is CVE-2026-107805?

CVE-2026-107805 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-107805?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-107805?

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107805?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107805 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →