Menu

Star on GitHub · 3.4k

CVE-2026-107806

7.2 · HIGH

Nginx UI is a web user interface for the Nginx web server.

Published Oct 9, 2026nginxuiCWE-94EPSS 0.57%

Overview

CVE-2026-107806 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Nginx UI is a web user interface for the Nginx web server. From 2.3.8 until 2.5.0, an authenticated administrator with an active secure session can submit attacker-controlled portable backup key material and a matching manifest to POST /api/restore. The restore flow trusts the supplied key, decrypts attacker-controlled contents, and replaces the live app.ini, including protected nginx command settings such as TestConfigCmd. Triggering POST /api/nginx/test then executes the restored command in the Nginx UI runtime context, affecting confidentiality, integrity, and availability. This issue is fixed in version 2.5.0.

Remediation

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
nginxuinginx_ui>= 2.3.8, < 2.5.0Affected

Frequently asked questions

What is CVE-2026-107806?

CVE-2026-107806 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

How severe is CVE-2026-107806?

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-107806?

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107806?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107806 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →