Menu

Star on GitHub · 3.4k

CVE-2026-107811

8.8 · HIGH

Nginx UI is a web user interface for the Nginx web server.

Published Oct 9, 2026nginxuiCWE-200EPSS 0.43%

Overview

CVE-2026-107811 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, ordinary authenticated users can access /api/nodes and /api/nodes/:id, whose responses serialize the node token field. The same token is accepted as X-Node-Secret by AuthRequired and maps the request to initUser, allowing the user to impersonate a trusted node against a reachable cluster member. This cross-node authentication bypass can expose sensitive management operations, including configuration synchronization and service restart. This issue is fixed in version 2.5.0.

Remediation

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
nginxuinginx_ui>= 2.0.0, < 2.5.0Affected

Frequently asked questions

What is CVE-2026-107811?

CVE-2026-107811 is a high-severity vulnerability affecting nginxui nginx_ui. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-107811?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-107811?

Check the references section for vendor advisories and patches from nginxui. Update nginx_ui to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107811?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107811 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →