Menu

Star on GitHub · 3.4k

CVE-2026-107814

8.4 · HIGH

MariaDB server is a community developed fork of MySQL server.

Published Oct 9, 2026mariadbCWE-732EPSS 0.49%

Overview

CVE-2026-107814 is a high-severity vulnerability affecting mariadb mariadb. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, MariaDB RPM packages created the dedicated mysql service account with the database data directory as its home directory. A database user with the FILE privilege could write startup dot-files such as .bash_profile into $HOME, and those files could execute when an administrator opened a login shell for the mysql account. Debian packages are not affected because they use /nonexistent as the account home. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Remediation

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mariadbmariadb>= 10.6.1, < 10.6.28Affected

Frequently asked questions

What is CVE-2026-107814?

CVE-2026-107814 is a high-severity vulnerability affecting mariadb mariadb. It was published on October 9, 2026 and has a CVSS 3.1 base score of 8.4 (HIGH).

How severe is CVE-2026-107814?

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-107814?

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107814?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107814 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →