Menu

Star on GitHub · 3.4k

CVE-2026-107816

6.4 · MEDIUM

MariaDB server is a community developed fork of MySQL server.

Published Oct 9, 2026mariadbCWE-125EPSS 0.34%

Overview

CVE-2026-107816 is a medium-severity vulnerability affecting mariadb mariadb. It was published on October 9, 2026 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the qc_info plugin could be confused by a query containing embedded null bytes. Reading information_schema.query_cache_info after such a query was cached could access data beyond the end of a heap-allocated buffer, potentially disclosing adjacent memory or crashing the server. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Remediation

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mariadbmariadb>= 10.6.1, < 10.6.28Affected

Frequently asked questions

What is CVE-2026-107816?

CVE-2026-107816 is a medium-severity vulnerability affecting mariadb mariadb. It was published on October 9, 2026 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

How severe is CVE-2026-107816?

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-107816?

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107816?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107816 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →